Back to overview
Resolved

FilBeam CDN retrieval issues for newly uploaded pieces

Jul 11, 2026 at 8:48am UTC
Affected services
FilBeam CDN

Resolved
Jul 16, 2026 at 5:09am UTC

Resolved: FilBeam CDN indexing and retrieval have been restored on Mainnet and Calibration. Both Goldsky pipelines are healthy, the replay backlog has fully cleared, and verification requests for outage-period and current pieces now return HTTP 200. The issue was caused by webhook delivery to retired filcdn.io endpoints; pipeline sinks and Worker routes now use filbeam.io. See https://github.com/filbeam/worker/issues/698 for details.

Created
Jul 11, 2026 at 8:48am UTC

We are investigating an indexing issue affecting FilBeam CDN on Mainnet and Calibration. Newly uploaded pieces may return 404 from CDN retrieval. Follow https://github.com/filbeam/worker/issues/698 for details and updates.